Welcome to weheartCHARICE. If you haven't already, we cordially invite you to register and join in on our discussions! Thanks!

Charice Fan Site and Forum

CHARICE just completed:      The 2012 TOFA-NY Awards - Carnegie Hall, New York (10/27/12)           and            Charice Infinity Tour 2012 - Honolulu, Hawaii (11/03/12)

You are not connected. Please login or register

Dolphy, Philippines' King of Comedy, in critical condition

Go down  Message [Page 1 of 1]


Dolphy in critical condition, says son

Posted at 06/20/2012 2:49 PM | Updated as of 06/20/2012 7:54 PM

MANILA, Philippines (UPDATED) -- King of Comedy Dolphy is now in critical condition, according to his son Eric Quizon.

But ABS-CBN correspondent Ginger Conejero later reported that the 84-year-old comedian has already been cleared of cleared of pneumonia.

Conejero said this was seen by the Quizon family as a positive development. However, she added that doctors are now concerned about the comedian's weakened kidneys.

In a text message sent to ABS-CBN News earlier on Wednesday, Quizon appealed for understanding if they can't talk about their father's condition right now.

Quizon also asked for prayers for his father's recovery.

Dad is critical at the moment. I hope you understand if I can't talk right now. Will update you later. We need your prayers," he texted.

Dolphy was rushed to the Makati Medical Center on June 9 due to pneumonia.

Last Monday, Quizon said that father was finally taken off his ventilator machine and was only dependent on an oxygen tank to assist in his breathing.

Quizon also said his family is grateful for all the prayers that were said for his dad, adding that they were overwhelmed by the amount of moral support their family received.

To those who are not familiar with Dolphy, Charice performed on his 80th birthday celebration back in 2008:
08/03/08 - Dolphy's 80th Birthday Special

Welcome to weheartCHARICE.com, a fan forum dedicated to the one and only Charice!

To view forum properly, please enable HTML by doing the following:

1. Go to "Profile" on your top menu
2. Click "Preferences"
3. Select "Yes" for Always allow HTML

Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum